aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch25
-rw-r--r--testing/libucontext/0002-x86-trampoline-kill-textrel.patch25
-rw-r--r--testing/libucontext/APKBUILD16
3 files changed, 4 insertions, 62 deletions
diff --git a/testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch b/testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
deleted file mode 100644
index 695501eb73..0000000000
--- a/testing/libucontext/0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 70089a405c006c6cae4480bd0307954983c48733 Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Wed, 14 Feb 2018 03:30:50 +0000
-Subject: [PATCH] build: use absolute path for LD_LIBRARY_PATH when testing
-
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index cc02c35..b524a2b 100644
---- a/Makefile
-+++ b/Makefile
-@@ -40,7 +40,7 @@ install: all
- ln -sf ${LIBUCONTEXT_SONAME} ${DESTDIR}/lib/${LIBUCONTEXT_NAME}
-
- check: test_libucontext ${LIBUCONTEXT_SONAME}
-- env LD_LIBRARY_PATH=. ./test_libucontext
-+ env LD_LIBRARY_PATH=$(shell pwd) ./test_libucontext
-
- test_libucontext: test_libucontext.c ${LIBUCONTEXT_NAME}
- $(CC) -std=c99 -D_BSD_SOURCE ${CFLAGS} ${CPPFLAGS} $@.c -o $@ ${LIBUCONTEXT_NAME}
---
-2.16.1
-
diff --git a/testing/libucontext/0002-x86-trampoline-kill-textrel.patch b/testing/libucontext/0002-x86-trampoline-kill-textrel.patch
deleted file mode 100644
index af60558ba4..0000000000
--- a/testing/libucontext/0002-x86-trampoline-kill-textrel.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 0143bbac98dfd55c4a42652bd1cce8d35047a861 Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Wed, 14 Feb 2018 03:37:25 +0000
-Subject: [PATCH 2/2] x86: trampoline: kill textrel
-
----
- arch/x86/startcontext.S | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/arch/x86/startcontext.S b/arch/x86/startcontext.S
-index 165804d..2bb87ee 100644
---- a/arch/x86/startcontext.S
-+++ b/arch/x86/startcontext.S
-@@ -18,7 +18,7 @@ __start_context:
- je hosed
-
- /* call setcontext to switch to the linked context */
-- call __setcontext
-+ call __setcontext@plt
- movl %eax, (%esp)
-
- hosed:
---
-2.16.1
-
diff --git a/testing/libucontext/APKBUILD b/testing/libucontext/APKBUILD
index fe44511c32..cf76b54729 100644
--- a/testing/libucontext/APKBUILD
+++ b/testing/libucontext/APKBUILD
@@ -1,21 +1,15 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libucontext
-pkgver=0.1.0
+pkgver=0.1.1
pkgrel=0
pkgdesc="ucontext function implementations"
url="http://github.com/kaniini/libucontext"
-
-# not available on s390x.
-# tests fail on x86 grsecurity for some reason, will be fixed in 0.2.0
-arch="all !x86 !s390x"
-
+arch="all"
license="ISC"
depends=""
install=""
subpackages="$pkgname-dev"
-source="https://distfiles.dereferenced.org/libucontext/libucontext-$pkgver.tar.xz
- 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
- 0002-x86-trampoline-kill-textrel.patch"
+source="https://distfiles.dereferenced.org/libucontext/libucontext-$pkgver.tar.xz"
builddir="$srcdir/libucontext-$pkgver"
case "$CTARGET_ARCH" in
@@ -38,6 +32,4 @@ package() {
make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
}
-sha512sums="abeae370317c53e6656842edd619e87202865d8f8808808f5ec5dfd40c259dcdc3ee530e0227ae602ca255215cf472e99ad1e3fbbb54f362c5a3cf744d9a1be4 libucontext-0.1.0.tar.xz
-26e1933e822ddc83086295144e5e8dc09602ad9200703b0e8c832bee0ee335c62c758d9847058bb28baf248f825d00604cfa1b4cb9b48234760c0e92cafb296a 0001-build-use-absolute-path-for-LD_LIBRARY_PATH-when-tes.patch
-dbcd8613379383fa488f525430383e2cf472c674b342f3f056f59081c73632fc8800bd22e1245ea5c2779039a095ed78bdac756f5037870115f4087b5dc3bd00 0002-x86-trampoline-kill-textrel.patch"
+sha512sums="a56dc9c4f9773f09b61079f96dba8cab74c89cbc9eec8373dd697793e18c7dc601bf47e47f3381a62400e25fe3d215d27ac1de11007f27af60e58c5804f67839 libucontext-0.1.1.tar.xz"