aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch36
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 29 insertions, 11 deletions
diff --git a/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch b/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch
index f328779a8d..82bd1222ab 100644
--- a/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch
+++ b/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch
@@ -1,4 +1,4 @@
-From 36a09262a3a82407ddd8a789734dfde1e6d46bfa Mon Sep 17 00:00:00 2001
+From 8e43e4ad948c5db6144d49d8968d30dbfb4b5afb Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Thu, 6 Jul 2017 13:39:15 +0200
Subject: [PATCH] udhcpc: Don't background if -n is given
@@ -16,15 +16,25 @@ See also: https://bugs.busybox.net/11691
[0]: https://git.busybox.net/busybox/commit/?id=87e216294af9eec39c0c1d553555f8a98c15db38
---
- networking/udhcp/d6_dhcpc.c | 8 +-------
+ networking/udhcp/d6_dhcpc.c | 20 +++++++-------------
networking/udhcp/dhcpc.c | 20 +++++++-------------
- 2 files changed, 8 insertions(+), 20 deletions(-)
+ 2 files changed, 14 insertions(+), 26 deletions(-)
diff --git a/networking/udhcp/d6_dhcpc.c b/networking/udhcp/d6_dhcpc.c
-index 422b88882..dab9d33a0 100644
+index 422b88882..f09bdf617 100644
--- a/networking/udhcp/d6_dhcpc.c
+++ b/networking/udhcp/d6_dhcpc.c
-@@ -1365,13 +1365,7 @@ int udhcpc6_main(int argc UNUSED_PARAM, char **argv)
+@@ -1360,25 +1360,19 @@ int udhcpc6_main(int argc UNUSED_PARAM, char **argv)
+ }
+ leasefail:
+ d6_run_script_no_option("leasefail");
++ if (opt & OPT_n) { /* abort if no lease */
++ bb_info_msg("no lease, failing");
++ retval = 1;
++ goto ret;
++ }
+ #if BB_MMU /* -b is not supported on NOMMU */
+ if (opt & OPT_b) { /* background if no lease */
bb_info_msg("no lease, forking to background");
client_background();
/* do not background again! */
@@ -35,12 +45,20 @@ index 422b88882..dab9d33a0 100644
- * (in a config file) to make it background
- * _and not exit_.
- */
+- } else
+-#endif
+- if (opt & OPT_n) { /* abort if no lease */
+- bb_info_msg("no lease, failing");
+- retval = 1;
+- goto ret;
+ opt = ((opt & ~OPT_b) | OPT_f);
- } else
- #endif
- if (opt & OPT_n) { /* abort if no lease */
+ }
++#endif
+ /* wait before trying again */
+ timeout = tryagain_timeout;
+ packet_num = 0;
diff --git a/networking/udhcp/dhcpc.c b/networking/udhcp/dhcpc.c
-index 739870bee..d09e2acca 100644
+index 95058dbd8..6501a1ba3 100644
--- a/networking/udhcp/dhcpc.c
+++ b/networking/udhcp/dhcpc.c
@@ -1478,25 +1478,19 @@ int udhcpc_main(int argc UNUSED_PARAM, char **argv)
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 4001b918fe..3567a2510b 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.31.0
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url="https://busybox.net/"
arch="all"
@@ -211,7 +211,7 @@ f96d66ce5a0295a2459a2c49c281b64e016de675ebd31a49af18cb06f3498fe27dfbc8667324b439
2c56906dac70dea6276e4c573707cb06c4c8b53defcd33b1e5a28f928e7dafe905a52ce40571de430e4af7e00a75ecc0f249d2fec02da5f3d9edd4e904919a35 0008-fbsplash-support-image-and-bar-alignment-and-positio.patch
907aef47c88f60e93bcd290eb43102721978ab6fc6eca52914172801ace7306ae8b11f38ed8b086452bbf46d75424740161e4f1e7840a485f0f78024455f902b 0009-depmod-support-generating-kmod-binary-index-files.patch
3b13ba6bd9b697e48864cb5376849c1ac95b30650e3e27605cc05edf4fdc1ecbb4c4503d4fe9012a581bcd660f6bb44d644575cf437d30423614cb83ee92c22c 0010-Add-flag-for-not-following-symlinks-when-recursing.patch
-e78a10d460e9cef545621b7b6d9da604865dc04e3a8202bdce1db9d697255818acc1150397c18101a104bc84b87de61209687e1fdc52cc244fd4fe4642a03b4e 0012-udhcpc-Don-t-background-if-n-is-given.patch
+b0f956e98ed1b670dc27f835441407d32395d371599780cf87a5fb2eee43ad2f77c8c484d20f08b1ed5d2bdee039668ff1a0b02561fa8206832072ab3b89cc45 0012-udhcpc-Don-t-background-if-n-is-given.patch
d8926f0e4ed7d2fe5af89ff2a944d781b45b109c9edf1ef2591e7bce2a8bbadd7c8ca814cb3c928ae09027d9603434fe70496f308d701f3d42260ebd1e9e9b29 0013-testsuite-fix-cpio-tests.patch
aa93095e20de88730f526c6f463cef711b290b9582cdbd8c1ba2bd290019150cbeaa7007c2e15f0362d5b9315dd63f60511878f0ea05e893f4fdfb4a54af3fb1 acpid.logrotate
ace97d165b80121968458f57d856d7f0b12ff342defe87c33ed5f994f7b00027b65f7389f6d23120a7d11449378e3d503552e87b17a3bb18337d74992b125b14 busyboxconfig