aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pynvim/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/py3-pynvim/APKBUILD b/testing/py3-pynvim/APKBUILD
index 14cad74cd6..63d2e55d05 100644
--- a/testing/py3-pynvim/APKBUILD
+++ b/testing/py3-pynvim/APKBUILD
@@ -3,14 +3,14 @@
pkgname="py3-pynvim"
_pyname="pynvim"
pkgver="0.4.0"
-pkgrel=0
+pkgrel=1
pkgdesc="python client and plugin host for Nvim"
url="https://github.com/neovim/pynvim"
arch="noarch"
-license="Apache"
+license="Apache-2.0"
depends="neovim python3 py3-msgpack py3-greenlet"
-makedepends="python3-dev"
-checkdepends="py3-pytest py3-pytest-runner"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-runner xvfb-run"
source="$_pyname-$pkgver.tar.gz::https://github.com/neovim/$_pyname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -19,7 +19,7 @@ build() {
}
check() {
- python3 setup.py test
+ xvfb-run python3 setup.py test
}
package() {