aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/deutex/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/deutex/APKBUILD b/testing/deutex/APKBUILD
new file mode 100644
index 0000000000..22190bb951
--- /dev/null
+++ b/testing/deutex/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname="deutex"
+pkgver="5.2.1"
+pkgrel=0
+pkgdesc="WAD composer for Doom, Heretic, Hexen, and Strife"
+url="https://github.com/Doom-Utils/deutex"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="autoconf automake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Doom-Utils/deutex/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ aclocal
+ autoheader
+ automake --add-missing
+ autoconf
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="976ba8ac3d3fef9cfec77272ed9b492abe1bae559633f4460c1a1f52ba373c0d2953831a18956afde0935ab7759c3bcb3274a8dec910c78af10044d0f568ba92 deutex-5.2.1.tar.gz"