aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libreoffice/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/libreoffice/APKBUILD b/community/libreoffice/APKBUILD
index afa9760e3a..33f1fd84f9 100644
--- a/community/libreoffice/APKBUILD
+++ b/community/libreoffice/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=libreoffice
pkgver=5.2.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="LibreOffice - Meta package for the full office suite"
url="http://www.libreoffice.org/"
arch="all"
@@ -22,7 +22,7 @@ makedepends="$depends_dev autoconf automake tar coreutils findutils ucpp gperf
install=""
subpackages="$pkgname-base $pkgname-calc $pkgname-common $pkgname-draw
$pkgname-gnome $pkgname-impress $pkgname-math
- $pkgname-connector-postgres $pkgname-writer"
+ $pkgname-connector-postgres $pkgname-writer libreofficekit"
depends="$subpackages"
_addsrcurl="http://dev-www.libreoffice.org/src"
case $pkgver in
@@ -248,6 +248,8 @@ build() {
sed -i -e 's:-isystem /usr/include[^/]::g' config_host.mk || return 1
make build-nocheck || return 1
+ # build libreofficekit
+ cd libreofficekit && make || return 1
}
package() {
@@ -300,6 +302,11 @@ impress() {
_split impress
}
+libreofficekit() {
+ mkdir -p "$subpkgdir"/usr/include
+ mv "$_builddir"/include/LibreOfficeKit "$subpkgdir"/usr/include || return 1
+}
+
math() {
pkgdesc="LibreOffice - Equation editor"
depends="libreoffice-common"