aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/git-secret/APKBUILD12
-rw-r--r--testing/git-secret/dont-hide-gpg-output.patch13
-rw-r--r--testing/git-secret/makefile.patch15
3 files changed, 4 insertions, 36 deletions
diff --git a/testing/git-secret/APKBUILD b/testing/git-secret/APKBUILD
index e3f705395c..b30999b029 100644
--- a/testing/git-secret/APKBUILD
+++ b/testing/git-secret/APKBUILD
@@ -4,8 +4,8 @@
# Note: git-secret is very badly designed, I'll replace this abuild once
# I find or write something better.
pkgname=git-secret
-pkgver=0.2.5
-pkgrel=1
+pkgver=0.2.6
+pkgrel=0
pkgdesc="A bash-tool to store your private data inside a git repository"
url="https://git-secret.io/"
arch="noarch"
@@ -13,9 +13,7 @@ license="MIT"
depends="bash gnupg"
checkdepends="bats"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sobolevn/$pkgname/archive/v$pkgver.tar.gz
- dont-hide-gpg-output.patch
- makefile.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sobolevn/$pkgname/archive/v$pkgver.tar.gz"
options="!check" # does not work in a container w/o tty
build() {
@@ -30,6 +28,4 @@ package() {
make PREFIX="$pkgdir/usr" install
}
-sha512sums="be4ff93db3ae1f4de2314d2b9fb9f0e671e2f01cb0927a2e5e939bc7082b825fe536a464b5f165caafe56fe30715a974182099c6827785194a2a42a837e31c8f git-secret-0.2.5.tar.gz
-102106c349797fe20eb32447b43d6ae70e44ba82a79fbc706c29a11cb76376394081fe10751b202346e703dd5eeae2494ea958071c7eee96a05927e544015b58 dont-hide-gpg-output.patch
-445cb34ccaaf5ed89a4db1e93e34f2fa63f3cdf63fbfc7d0fa592cfc030d4fcfd697c377e20695dc7566143aa7559ffa463169d606255eafa9e296e623fe8ff1 makefile.patch"
+sha512sums="9f83265d17eeb077882602fe3a69a161629e2fbe983b583c048bf55d0590a50d232d19fc8b89a599bcbe5f6280049f21a527b41985ffbc59ee52e01beb2d7ba2 git-secret-0.2.6.tar.gz"
diff --git a/testing/git-secret/dont-hide-gpg-output.patch b/testing/git-secret/dont-hide-gpg-output.patch
deleted file mode 100644
index 234834fe6f..0000000000
--- a/testing/git-secret/dont-hide-gpg-output.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Goddamn, don't make troubleshooting impossible!
-
---- a/src/commands/git_secret_tell.sh
-+++ b/src/commands/git_secret_tell.sh
-@@ -95,7 +95,7 @@ function tell {
- # Importing public key to the local keychain:
- local secrets_dir_keys
- secrets_dir_keys=$(_get_secrets_dir_keys)
-- $SECRETS_GPG_COMMAND --homedir "$secrets_dir_keys" --no-permission-warning --import "$keyfile" > /dev/null 2>&1
-+ $SECRETS_GPG_COMMAND --homedir "$secrets_dir_keys" --no-permission-warning --import "$keyfile"
- exit_code=$?
- if [[ "$exit_code" -ne 0 ]]; then
- _abort "problem importing public key for '$email' with gpg: exit code $exit_code"
diff --git a/testing/git-secret/makefile.patch b/testing/git-secret/makefile.patch
deleted file mode 100644
index 3f049658ea..0000000000
--- a/testing/git-secret/makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -40,10 +40,10 @@ install-test:
- fi
-
- .PHONY: test
--test: install-test clean build
-+test: build
- @chmod +x "./utils/tests.sh"; sync; \
- export SECRET_PROJECT_ROOT="${PWD}"; \
-- export PATH="${PWD}/vendor/bats-core/bin:${PWD}:${PATH}"; \
-+ export PATH="${PWD}:${PATH}"; \
- "./utils/tests.sh"
-
- #