aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/rtmpdump/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/main/rtmpdump/APKBUILD b/main/rtmpdump/APKBUILD
index 95807b536b..9730ebc2ee 100644
--- a/main/rtmpdump/APKBUILD
+++ b/main/rtmpdump/APKBUILD
@@ -3,14 +3,15 @@
pkgname=rtmpdump
verbase=2.4
pkgver=2.4_git20160909
-pkgrel=3
+pkgrel=4
pkgdesc="A tool to download rtmp:// and rtmpe:// streams"
url="http://rtmpdump.mplayerhq.hu/"
arch="all"
-license="GPL"
+options="!check" # No test suite.
+license="GPL-2.0+"
depends=
-depends_dev="zlib-dev libressl-dev"
-makedepends="$depends_dev linux-headers"
+depends_dev="zlib-dev"
+makedepends="$depends_dev linux-headers libressl-dev"
subpackages="$pkgname-dev $pkgname-doc librtmp"
giturl="git://git.ffmpeg.org/rtmpdump"
@@ -22,13 +23,12 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
make -j1 prefix=/usr MANDIR="$pkgdir/usr/share/man" DESTDIR="$pkgdir" install
-
}
librtmp() {
@@ -38,9 +38,5 @@ librtmp() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
}
-md5sums="efe6e25213e8494cb0ef49d770ff328d rtmpdump-2.4_git20160909.tar.gz
-8a6331a036a40c8be551e472bc2fe11c fix-chunk-size.patch"
-sha256sums="618f37762a4aea7a1a357d75479fa8e85198b761ca8c6c50d675e650b27f7991 rtmpdump-2.4_git20160909.tar.gz
-99f4204f1bb18709cc85235f6e041125f221e181e091525eea19f17c713fab43 fix-chunk-size.patch"
sha512sums="e42eda75679addb6f919f42ddce2d27a6988f505602bb70ecb4d071324b59f21d573f8b73fda3b29960c095e20303b84f6eb6254cd327803430d8065cf5d172b rtmpdump-2.4_git20160909.tar.gz
f97b4780fb8cfffccf59785c5a89c8d4929e21ec587192f10602caaf9a0b008dfbfebaa09db1d9d955fc9911fc443d76bf19972cc59fedfab5a8889f7fe70b5d fix-chunk-size.patch"