aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-secretstorage/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-secretstorage/APKBUILD b/testing/py3-secretstorage/APKBUILD
new file mode 100644
index 0000000000..80d8a970fb
--- /dev/null
+++ b/testing/py3-secretstorage/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-secretstorage
+_pkgname="SecretStorage"
+pkgver=3.1.1
+pkgrel=0
+pkgdesc="Python bindings to Freedesktop.org Secret Service API"
+url="https://github.com/mitya57/secretstorage"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-setuptools"
+source=" https://files.pythonhosted.org/packages/source/S/SecretStorage/SecretStorage-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="295e0f75c772edf153480730dc20051f06e60e040a18f169620cb4aaa37b8c1a254a496464d3794a38cf49fa884a7b561fe364816f0d12a5b2622c77259f03cf SecretStorage-3.1.1.tar.gz"