aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/multipath-tools/0001-OPTFLAGS-patch.patch26
-rw-r--r--main/multipath-tools/APKBUILD14
2 files changed, 34 insertions, 6 deletions
diff --git a/main/multipath-tools/0001-OPTFLAGS-patch.patch b/main/multipath-tools/0001-OPTFLAGS-patch.patch
new file mode 100644
index 0000000000..0e7e0db06c
--- /dev/null
+++ b/main/multipath-tools/0001-OPTFLAGS-patch.patch
@@ -0,0 +1,26 @@
+From c42ef66d93ad183a832c9c62a4c909a4cff27358 Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Thu, 7 May 2020 07:39:30 +0000
+Subject: [PATCH] OPTFLAGS patch
+
+Remove Werror and O2
+---
+ Makefile.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.inc b/Makefile.inc
+index d4d1e0d..fa39f25 100644
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -93,7 +93,7 @@ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
+ ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
+ WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered,)
+
+-OPTFLAGS = -O2 -g -pipe -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
++OPTFLAGS = -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Werror=format-security \
+ $(WNOCLOBBERED) \
+ -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) \
+--
+2.26.0
+
diff --git a/main/multipath-tools/APKBUILD b/main/multipath-tools/APKBUILD
index 38c7c7cf62..e5a517b7fc 100644
--- a/main/multipath-tools/APKBUILD
+++ b/main/multipath-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=multipath-tools
-pkgver=0.8.3
-pkgrel=5
+pkgver=0.8.4
+pkgrel=0
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr"
arch="all"
@@ -15,9 +15,10 @@ source="$pkgname-$pkgver.tar.gz::https://git.opensvc.com/gitweb.cgi?p=multipath-
multipath-tools.conf
multipath.initd
multipathd.initd
+
+ 0001-OPTFLAGS-patch.patch
"
options="!check"
-builddir="$srcdir/multipath-tools"
prepare() {
# Rename unpacked directory with hash in the name to something sane...
@@ -27,7 +28,7 @@ prepare() {
}
build() {
- make prefix="/usr" \
+ make -j1 prefix="/usr" \
sysconfdir="/etc" \
mandir="/usr/share/man" \
infodir="/usr/share/info"
@@ -44,8 +45,9 @@ package() {
"$pkgdir"/etc/init.d/multipath
}
-sha512sums="d9fdc2763f5a1efa15ee07c5d863008c9694623935f62a0e0b56f941df4e0d0ca3f86056fefc9b5ca828b47782127e3d55f2f925b1ed957e02b675bef36f4cae multipath-tools-0.8.3.tar.gz
+sha512sums="720823188c053c1c50269a30e34a9d69099098495bfd607076bcfa2c079565e3f0580c91783f19d42ed82290c0db98e4e19ef620eca4ee5ec7885c49c72d2307 multipath-tools-0.8.4.tar.gz
fae0e1fbc7dfe6d932a5b19e9a80efdc30a2bad3ac4e24ff2f8ec9b156107378b5f15d4bec8c32dbfd87286cd7e30b4acebfadda416365f108dafeea0321318a json-c-0.14.patch
e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a134e1255c66421c6fde39d54b15eef975e8df81bdc88b2213 multipath-tools.conf
97deeee57daee787d807da0a4dbf50baae047ddcda30925f7000ec822b5a17a3dc55196c3e032c8ffbc2caeac690ce5ca485b0a7c99f15e66bddaa000439112a multipath.initd
-2f913fed199f12f048eb042b5bb1a326f6f09cfe63d572ac269461d96ebf25b251576de22be7ba9ab631ded7af6fd47dac38fda3b29d00640c806181eb37447c multipathd.initd"
+2f913fed199f12f048eb042b5bb1a326f6f09cfe63d572ac269461d96ebf25b251576de22be7ba9ab631ded7af6fd47dac38fda3b29d00640c806181eb37447c multipathd.initd
+909054c95bd2ee6a2651ad2849c4308342ba17c05ce557dc751c0ce3efc8a10f733cb6efa25d07b1f519858c05dadaf6622fac6e233a02cfedf53f99f28065d9 0001-OPTFLAGS-patch.patch"