aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--extra/libconfig/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/extra/libconfig/APKBUILD b/extra/libconfig/APKBUILD
new file mode 100644
index 0000000000..cf1d05a9be
--- /dev/null
+++ b/extra/libconfig/APKBUILD
@@ -0,0 +1,22 @@
+pkgname=libconfig
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="a simple library for manipulating structured configuration files"
+url="http://www.hyperrealm.com/libconfig/"
+license='LGPL'
+depends="uclibc"
+source="http://www.hyperrealm.com/$pkgname/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-dev"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-cxx
+ make || return 1
+ make DESTDIR="$pkgdir/" install
+}
+
+md5sums="" #generate with 'abuild checksum'
+md5sums="f02bfa27a21b3040089026975b9dc0b8 libconfig-1.3.1.tar.gz"