aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/perl-future/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/main/perl-future/APKBUILD b/main/perl-future/APKBUILD
index 8611e1205e..6608b4f010 100644
--- a/main/perl-future/APKBUILD
+++ b/main/perl-future/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-future
_pkgreal=Future
-pkgver=0.41
+pkgver=0.42
pkgrel=0
pkgdesc="Represent an operation awaiting completion"
url="https://metacpan.org/release/Future"
@@ -17,26 +17,22 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
perl Build.PL installdirs=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="b704acaed4a2f87fa64b72cc183567214d3e67849b2ae3053f97fef88d278f42589053b9f7c8a218b2eca31f93692e3d252966e0a3d1d54a7e15d172162570b8 Future-0.41.tar.gz"
+sha512sums="ab08a9e3d5d216b342a3fea2273e387b907425d12872abf5efa79eb18f2cc888f5063b011fe32d64b4862195814a713077f1b8325fc27659e96dbca46f98fa05 Future-0.42.tar.gz"