aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pylint/APKBUILD23
-rw-r--r--testing/pylint/APKBUILD47
2 files changed, 23 insertions, 47 deletions
diff --git a/testing/py3-pylint/APKBUILD b/testing/py3-pylint/APKBUILD
new file mode 100644
index 0000000000..6c35a3def2
--- /dev/null
+++ b/testing/py3-pylint/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pylint
+_pkgname=pylint
+pkgver=1.7.4
+pkgrel=2
+pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
+url="https://github.com/PyCQA/pylint"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="py3-astroid py3-isort py3-mccabe py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c1d671e53141df9fbe55a0e285bb6f5199c2a778f56759c41292835cbad7cb4aa4b6152116d85aa9b77cbbabd15d2b8573fa2e86accd2b243e96175abd2b2bf1 pylint-1.7.4.tar.gz"
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
deleted file mode 100644
index 87374f2835..0000000000
--- a/testing/pylint/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=pylint
-pkgver=1.7.4
-pkgrel=2
-pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
-url="http://pypi.python.org/pypi/pylint"
-arch="noarch"
-license="GPL-2.0-or-later"
-depends="py-mccabe py-six py-isort py-astroid"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="c1d671e53141df9fbe55a0e285bb6f5199c2a778f56759c41292835cbad7cb4aa4b6152116d85aa9b77cbbabd15d2b8573fa2e86accd2b243e96175abd2b2bf1 pylint-1.7.4.tar.gz"