aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/numactl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/numactl/APKBUILD b/testing/numactl/APKBUILD
index 96f5c7ee30..dec2786503 100644
--- a/testing/numactl/APKBUILD
+++ b/testing/numactl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=numactl
pkgver=2.0.12
-pkgrel=0
+pkgrel=1
pkgdesc="Simple NUMA policy support"
url="https://github.com/numactl/numactl"
# ARM lacks the __NR_migrate_pages syscall
@@ -9,7 +9,6 @@ arch="all !armhf !armv7"
license="GPL-2.0 LGPL-2.0"
makedepends="autoconf automake libtool linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/numactl/$pkgname/archive/v$pkgver.tar.gz
musl.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -21,6 +20,11 @@ prepare() {
./autogen.sh
}
+check() {
+ cd "$builddir"
+ make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
+}
+
build() {
cd "$builddir"
./configure \