aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libressl/APKBUILD4
-rw-r--r--main/libressl/starttls-ldap.patch9
2 files changed, 11 insertions, 2 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index 17bae94f3a..ec586d2891 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -9,7 +9,7 @@
pkgname=libressl
pkgver=2.5.5
_namever=${pkgname}${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
@@ -65,4 +65,4 @@ _libs() {
}
sha512sums="3f576e74ddea17bd72e1bfbe0b57b94e1a2a9e6fa56cee50624cd8d18f0a8674273086225669e6ece56e6b859d2376e36e2c140d37acb52d4cd79374c4ba7096 libressl-2.5.5.tar.gz
-18fe5f83aa5944d644a67e4a294deaf772c42d0696ff38e075f7265070269b09dc001a9bf2bab3fb8200f8ce66346d189d48884859727c7d5ad30398ed76a948 starttls-ldap.patch"
+07e523ae321b4a6a4afbac7acf4bd30e887b8e18ab2801ca42ba48af130b1cb43d56e70d1039b248c6251623b57c1c638db59105e6fbf4e6175be50d67a0473d starttls-ldap.patch"
diff --git a/main/libressl/starttls-ldap.patch b/main/libressl/starttls-ldap.patch
index 55319ed04c..94cf3d01f7 100644
--- a/main/libressl/starttls-ldap.patch
+++ b/main/libressl/starttls-ldap.patch
@@ -1,5 +1,14 @@
--- libressl-2.5.5/apps/openssl/s_client.c
+++ libressl-2.5.5.ldap/apps/openssl/s_client.c
+@@ -56,7 +56,7 @@
+ * [including the GNU Public Licence.]
+ */
+ /* ====================================================================
+- * Copyright (c) 1998-2006 The OpenSSL Project. All rights reserved.
++ * Copyright (c) 1998-2017 The OpenSSL Project. All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
@@ -184,6 +184,7 @@
static void sc_usage(void);
static void print_stuff(BIO * berr, SSL * con, int full);