aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-pluggy/APKBUILD7
-rw-r--r--testing/py-tox/APKBUILD57
2 files changed, 59 insertions, 5 deletions
diff --git a/testing/py-pluggy/APKBUILD b/testing/py-pluggy/APKBUILD
index 62ab9a3b54..5b192619a6 100644
--- a/testing/py-pluggy/APKBUILD
+++ b/testing/py-pluggy/APKBUILD
@@ -45,12 +45,9 @@ _py() {
}
check() {
- cd "$builddir"
+ cd "$builddir"
sed -i 's|envlist.*|envlist=check,py{27,36}-pytest{30}|' tox.ini
- tox
+ tox
}
-
-
-
sha512sums="dea3cdc045d295adf99ef1932ffad542bf57d5ecd91f5b48815f0a65e5f7ffd56e8e727436a20c83e5c261995092a0c561c81a5b20566f97768a24be1dd52eb1 py-pluggy-0.4.0.tar.gz"
diff --git a/testing/py-tox/APKBUILD b/testing/py-tox/APKBUILD
new file mode 100644
index 0000000000..5ba21f123e
--- /dev/null
+++ b/testing/py-tox/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py-tox
+_pkgname=${pkgname#py-*}
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="virtualenv management and test command line tool"
+url="https://tox.readthedocs.org/"
+arch="noarch"
+license="MIT"
+_depends="py-virtualenv"
+depends="py-py py-pluggy py-argparse"
+makedepends="python2-dev python3-dev py-setuptools"
+options="!check" # temp disable as requires itself
+#checkdepends="py-tox"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tox-dev/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-} $_depends"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+check() {
+ cd "$builddir"
+ sed -i 's|envlist.*|envlist=check,py{27,36}-pytest{30},flakes|' tox.ini
+ tox
+}
+
+sha512sums="ff300e2ee21f66a50365709ea71b68394b2207496e9858ff09012dfcd63527ba8404835a233d30b732a603ea774d8b86a169f874db8ca8cc66733a545cd41e19 py-tox-2.7.0.tar.gz"