aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/emscripten-fastcomp/APKBUILD21
-rw-r--r--community/emscripten-fastcomp/llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch33
-rw-r--r--community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch30
3 files changed, 8 insertions, 76 deletions
diff --git a/community/emscripten-fastcomp/APKBUILD b/community/emscripten-fastcomp/APKBUILD
index bdab4978a7..f659665ee7 100644
--- a/community/emscripten-fastcomp/APKBUILD
+++ b/community/emscripten-fastcomp/APKBUILD
@@ -7,21 +7,18 @@
# TODO: Remove unneeded binaries.
pkgname=emscripten-fastcomp
# Keep in sync with package emscripten!
-pkgver=1.37.10
-pkgrel=2
+pkgver=1.39.0
+pkgrel=0
pkgdesc="The Clang + LLVM backend for Emscripten"
-url="https://kripken.github.io/emscripten-site/"
+url="https://emscripten.org/"
arch="all"
license="UOI-NCSA"
depends="python2"
makedepends="cmake paxmark zlib-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kripken/$pkgname/archive/$pkgver.tar.gz
- $pkgname-clang-$pkgver.tar.gz::https://github.com/kripken/$pkgname-clang/archive/$pkgver.tar.gz
+source="emscripten-fastcomp-$pkgver.tar.gz::https://github.com/emscripten-core/emscripten-fastcomp/archive/$pkgver.tar.gz
+ emscripten-fastcomp-clang-$pkgver.tar.gz::https://github.com/emscripten-core/emscripten-fastcomp-clang/archive/$pkgver.tar.gz
llvm-fix-build-with-musl-libc.patch
- llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
- llvm-fix-return-type-in-ORC-readMem-client-interface.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check" # some tests are broken, don't bother with it for now
_prefix="usr/lib/$pkgname"
@@ -80,8 +77,6 @@ package() {
rm lib/*.a bin/*-test
}
-sha512sums="8a7ab29f2b239eef43bfcea3359847d9566aecd1252f6f27685e43bb71ef9031d3dffc14f07fdf97979461ea4e07140510aebec315ab4fdfaec9fcb944370c6a emscripten-fastcomp-1.37.10.tar.gz
-54442b598001204420087b7ff6168c34a626e39a3992a343294cdc9c9a93020ca8de19365d15afc97d35ff94f584f50663e0b843696596f3ad3441608d974270 emscripten-fastcomp-clang-1.37.10.tar.gz
-f84cd65d7042e89826ba6e8d48c4c302bf4980da369d7f19a55f217e51c00ca8ed178d453df3a3cee76598a7cecb94aed0775a6d24fe73266f82749913fc3e71 llvm-fix-build-with-musl-libc.patch
-19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
-f57c734687c8ceae8d1bbfcbfdeecb75a5059a112967f4ba639d78d2484e0cc1deabf02ba2d3a6f5283443bf8b3230f38ad143800f8f3327cca0d2691a3ddc3d llvm-fix-return-type-in-ORC-readMem-client-interface.patch"
+sha512sums="574e5b4cf86f16ae455b1f399ecec414f4d791b1b3b49afcd21e967bad62efc572e9f4cd1d2bdce050214ab25e419149bdbfc89cc868ab1019d6ca24c245db63 emscripten-fastcomp-1.39.0.tar.gz
+58422eabd5795d1f9a5806862e7e2ec4489542227765064fa2f7f0930a6b96b59185302ded976189666a4fb452450fbfb37a525b8c7a3d1cc33b7e39b9909dcf emscripten-fastcomp-clang-1.39.0.tar.gz
+f84cd65d7042e89826ba6e8d48c4c302bf4980da369d7f19a55f217e51c00ca8ed178d453df3a3cee76598a7cecb94aed0775a6d24fe73266f82749913fc3e71 llvm-fix-build-with-musl-libc.patch"
diff --git a/community/emscripten-fastcomp/llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch b/community/emscripten-fastcomp/llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
deleted file mode 100644
index d5d7f07b5e..0000000000
--- a/community/emscripten-fastcomp/llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d12ecb83d01dcb580dd94f4d57828f33d3eb4c35 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 18 Feb 2016 15:33:21 +0100
-Subject: [PATCH 3/3] Fix DynamicLibrary to build with musl libc
-
-stdin/out/err is part of the libc and not the kernel so we check for the
-specific libc that does the unexpected instead of linux.
-
-This is needed for making it build with musl libc.
----
- lib/Support/DynamicLibrary.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/Support/DynamicLibrary.cpp b/lib/Support/DynamicLibrary.cpp
-index 9a7aeb5..0c1c8f8 100644
---- a/lib/Support/DynamicLibrary.cpp
-+++ b/lib/Support/DynamicLibrary.cpp
-@@ -140,10 +140,10 @@ void* DynamicLibrary::SearchForAddressOfSymbol(const char *symbolName) {
- #define EXPLICIT_SYMBOL(SYM) \
- if (!strcmp(symbolName, #SYM)) return &SYM
-
--// On linux we have a weird situation. The stderr/out/in symbols are both
-+// On GNU libc we have a weird situation. The stderr/out/in symbols are both
- // macros and global variables because of standards requirements. So, we
- // boldly use the EXPLICIT_SYMBOL macro without checking for a #define first.
--#if defined(__linux__) and !defined(__ANDROID__)
-+#if defined(__GLIBC__)
- {
- EXPLICIT_SYMBOL(stderr);
- EXPLICIT_SYMBOL(stdout);
---
-2.7.3
-
diff --git a/community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch b/community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch
deleted file mode 100644
index 5296fdb0ba..0000000000
--- a/community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 5cea35478aaaac7728a50cbafd3770f96162f7ac Mon Sep 17 00:00:00 2001
-From: Tilmann Scheller <tschelle@redhat.com>
-Date: Thu, 1 Feb 2018 11:40:01 -0600
-Subject: [PATCH] Fix return type in ORC readMem() client interface.
-
-GCC 8.0.1 detects the type mismatch and causes the compilation to fail. Clang
-and earlier versions of GCC don't detect the issue.
-
-Fixes rhbz#1540620.
----
- include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-index da02250ba16..bed472e2e0e 100644
---- a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-+++ b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-@@ -713,8 +713,8 @@ private:
-
- uint32_t getTrampolineSize() const { return RemoteTrampolineSize; }
-
-- Expected<std::vector<char>> readMem(char *Dst, JITTargetAddress Src,
-- uint64_t Size) {
-+ Expected<std::vector<uint8_t>> readMem(char *Dst, JITTargetAddress Src,
-+ uint64_t Size) {
- // Check for an 'out-of-band' error, e.g. from an MM destructor.
- if (ExistingError)
- return std::move(ExistingError);
---
-2.16.1