aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-allfiles/APKBUILD (renamed from testing/py-allfiles/APKBUILD)12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-allfiles/APKBUILD b/testing/py3-allfiles/APKBUILD
index 3841234908..590f9c3f45 100644
--- a/testing/py-allfiles/APKBUILD
+++ b/testing/py3-allfiles/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-allfiles
+pkgname=py3-allfiles
_pkgname=allfiles
pkgver=1.0
pkgrel=0
@@ -8,9 +8,11 @@ pkgdesc="A Python iterator for matching files in directory trees"
url="https://pypi.python.org/pypi/allfiles"
arch="noarch"
license="MIT"
-depends="python2"
+replaces="py-allfiles" # for backwards compatibility
+provides="py-allfiles=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="py3-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
@@ -28,12 +30,12 @@ prepare() {
build() {
cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="d25991ebdc6277f60b90057c565f3b2d allfiles-1.0.zip"