aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/lua5.3/APKBUILD41
1 files changed, 17 insertions, 24 deletions
diff --git a/main/lua5.3/APKBUILD b/main/lua5.3/APKBUILD
index b1baf7b75a..58b47ef499 100644
--- a/main/lua5.3/APKBUILD
+++ b/main/lua5.3/APKBUILD
@@ -3,7 +3,7 @@ pkgname=lua5.3
_pkgname=lua
pkgver=5.3.5
_luaver=${pkgname#lua}
-pkgrel=2
+pkgrel=3
pkgdesc="Powerful light-weight programming language"
url="https://www.lua.org/"
arch="all"
@@ -23,12 +23,10 @@ builddir="$srcdir/$_pkgname-$pkgver"
# secfixes:
# 5.3.5-r2:
-# - CVE-2019-6706
+# - CVE-2019-6706
prepare() {
default_prepare
- cd "$builddir"
-
# disable readline
sed -i '/#define LUA_USE_READLINE/d' src/luaconf.h
@@ -44,8 +42,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -53,7 +49,7 @@ build() {
cd src
make V=${pkgver%.*} \
- CFLAGS="-DLUA_USE_LINUX -DLUA_COMPAT_5_2 -DLUA_USE_LINENOISE" \
+ CFLAGS="$CFLAGS -DLUA_USE_LINUX -DLUA_COMPAT_5_2 -DLUA_USE_LINENOISE" \
SYSLDFLAGS="$LDFLAGS" \
RPATH="/usr/lib" \
LIB_LIBS="-lpthread -lm -ldl -llinenoise" \
@@ -61,14 +57,11 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
local i
- cd "$builddir"
-
make V=${pkgver%.*} \
INSTALL_TOP="$pkgdir"/usr \
INSTALL_INC="$pkgdir"/usr/include/$pkgname \
@@ -93,30 +86,30 @@ package() {
# vars from install Makefile
# grep '^V=' ../Makefile
- V= ${_luaver}
+ V= $_luaver
# grep '^R=' ../Makefile
- R= ${pkgver}
+ R= $pkgver
# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
prefix= /usr
- INSTALL_BIN= \${prefix}/bin
- INSTALL_INC= \${prefix}/include
- INSTALL_LIB= \${prefix}/lib
- INSTALL_MAN= \${prefix}/man/man1
- INSTALL_LMOD= \${prefix}/share/lua/\${V}
- INSTALL_CMOD= \${prefix}/lib/lua/\${V}
+ INSTALL_BIN= \$prefix/bin
+ INSTALL_INC= \$prefix/include
+ INSTALL_LIB= \$prefix/lib
+ INSTALL_MAN= \$prefix/man/man1
+ INSTALL_LMOD= \$prefix/share/lua/\$V
+ INSTALL_CMOD= \$prefix/lib/lua/\$V
# canonical vars
- exec_prefix=\${prefix}
- libdir=\${exec_prefix}/lib/$pkgname
- includedir=\${prefix}/include/$pkgname
+ exec_prefix=\$prefix
+ libdir=\$exec_prefix/lib/$pkgname
+ includedir=\$prefix/include/$pkgname
Name: Lua
Description: An Extensible Extension Language
- Version: \${R}
+ Version: \$R
Requires:
- Libs: -L\${libdir} -llua -lm
- Cflags: -I\${includedir}
+ Libs: -L\$libdir -llua -lm
+ Cflags: -I\$includedir
# (end of lua$_luaver.pc)
EOF