aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libinput/APKBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/main/libinput/APKBUILD b/main/libinput/APKBUILD
index b2c1634e92..04e10957f0 100644
--- a/main/libinput/APKBUILD
+++ b/main/libinput/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=libinput
-pkgver=1.7.3
-pkgrel=1
+pkgver=1.8.1
+pkgrel=0
pkgdesc="Library for handling input devices"
url="http://www.freedesktop.org/wiki/Software/libinput/"
arch="all"
-license="custom"
+license="MIT"
depends=""
makedepends="mtdev-dev eudev-dev libevdev-dev grep"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
options="!check"
source="http://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -21,10 +21,13 @@ build() {
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
+ --libexecdir=/usr/lib \
--mandir=/usr/share/man \
- --localstatedir=/var \
--with-udev-dir=/lib/udev \
- --disable-libwacom
+ --disable-documentation \
+ --disable-debug-gui \
+ --disable-libwacom \
+ --disable-tests
make
}
@@ -32,4 +35,11 @@ package() {
make DESTDIR="$pkgdir" -C "$builddir" install
}
-sha512sums="2262dc56d213a4d3ea765e870af200e2c336a166baa1bbdf5205e3ce70faefc777429ba09563c5dd79feb5442f53abc84e04a0f32a06bb622d6e120bb8ad152b libinput-1.7.3.tar.xz"
+libs() {
+ default_libs
+ mv "$pkgdir"/lib "$subpkgdir"/
+ mv "$pkgdir"/usr/lib/* "$subpkgdir"/usr/lib
+ rmdir "$pkgdir"/usr/lib
+}
+
+sha512sums="1566ccb7d1721ee2d16badc404896d31e3ac45fda71e2577db17141a507594f3827ed0a389bb537f946cb380d77feedef8e71df76ac89f8c11c44463df01ee4f libinput-1.8.1.tar.xz"