aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/rust/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index d24b4d9e08..55892cad97 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -101,8 +101,6 @@ build() {
# jemalloc is disabled, because it increases size of statically linked
# binaries produced by rustc (stripped hello_world 186 kiB vs. 358 kiB)
# for only tiny performance boost (even negative in some tests).
- # TODO: Remove --set="rust.deny-warnings=false" with upgrade to 1.28.0,
- # it's workaround for https://github.com/rust-lang/rust/issues/51650.
./configure \
--build="$CBUILD" \
--host="$CTARGET" \
@@ -120,8 +118,7 @@ build() {
--enable-option-checking \
--enable-locked-deps \
--enable-vendor \
- --disable-jemalloc \
- --set="rust.deny-warnings=false"
+ --disable-jemalloc
./x.py build -v --jobs ${JOBS:-2}
}