aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/nfs-utils/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/nfs-utils/APKBUILD b/main/nfs-utils/APKBUILD
index fa0b9b49f9..62add782da 100644
--- a/main/nfs-utils/APKBUILD
+++ b/main/nfs-utils/APKBUILD
@@ -10,7 +10,9 @@ license="GPL"
depends="rpcbind"
makedepends="util-linux-dev libtirpc-dev libcap-dev libevent-dev
libnfsidmap-dev keyutils-dev lvm2-dev"
-subpackages="$pkgname-doc rpcgen"
+subpackages="$pkgname-doc"
+[ "$ALPINE_LIBC" != "eglibc" ] && subpackages="$subpackages rpcgen"
+
source="http://downloads.sourceforge.net/nfs/$pkgname-$pkgver.tar.bz2
nfs.initd
nfsmount.initd
@@ -32,13 +34,15 @@ prepare() {
msg "Applying $i"
patch -p0 -i "${i}" || return 1
done
- sed -i -e '/^#include <libio.h>/d' support/include/sockaddr.h
+ # fix build on eglibc
+ sed -i -e '/^#include <libio.h>/d' \
+ support/include/sockaddr.h || return 1
# busybox install fix
sed -i 's/--mode 755/-m755/g' \
tools/nfs-iostat/Makefile.am \
tools/nfs-iostat/Makefile.in \
tools/mountstats/Makefile.am \
- tools/mountstats/Makefile.in
+ tools/mountstats/Makefile.in || return 1
}
build() {