aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/signond/APKBUILD36
-rw-r--r--testing/signond/busybox-incompatibility.patch14
2 files changed, 50 insertions, 0 deletions
diff --git a/testing/signond/APKBUILD b/testing/signond/APKBUILD
new file mode 100644
index 0000000000..aea7ba770c
--- /dev/null
+++ b/testing/signond/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=signond
+pkgver=8.60
+pkgrel=0
+arch="all"
+url="https://gitlab.com/accounts-sso/signond"
+pkgdesc="A D-Bus service which performs user authentication on behalf of its clients"
+license="LGPL-2.1-only"
+makedepends="qt5-qtbase-dev doxygen graphviz"
+checkdepends="dbus-x11"
+source="https://gitlab.com/accounts-sso/$pkgname/-/archive/VERSION_$pkgver/$pkgname-VERSION_$pkgver.tar.gz
+ busybox-incompatibility.patch"
+subpackages="$pkgname-doc $pkgname-static $pkgname-dev"
+if [ "$CARCH" = armv7 ]; then
+ options="!check" # Broken
+fi
+builddir="$srcdir/$pkgname-VERSION_$pkgver"
+
+build() {
+ qmake-qt5 \
+ PREFIX=/usr \
+ LIBDIR=/usr/lib
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="fb3ccc99c692506ca29d5bae39bc375ff97057734fac1551ea39105d5f8e78f3df23e01a286f73be3a606c54b40f957c3c0d985484926e57f354218e4137ff3c signond-VERSION_8.60.tar.gz
+1fb27bd57d9478f17d0a53b9e9efb598bb10323f8f8887b7bda768ec11abe830c46620abffe95ed6361283522967d62457d6a120a0b28b3fe100c8dbeb5e9b9a busybox-incompatibility.patch"
diff --git a/testing/signond/busybox-incompatibility.patch b/testing/signond/busybox-incompatibility.patch
new file mode 100644
index 0000000000..25028a2fa3
--- /dev/null
+++ b/testing/signond/busybox-incompatibility.patch
@@ -0,0 +1,14 @@
+diff --git a/tests/run-with-signond.sh b/tests/run-with-signond.sh
+index ad04b03..e6d2540 100755
+--- a/tests/run-with-signond.sh
++++ b/tests/run-with-signond.sh
+@@ -6,7 +6,8 @@ set -e
+
+ # start a local signond
+
+-export HOME="$(mktemp -d --tmpdir signond-tests-XXXXXX)"
++
++export HOME="$(mktemp -d)"
+ export SSO_LOGGING_LEVEL=2
+ export SSO_STORAGE_PATH="${HOME}"
+ export SSO_DAEMON_TIMEOUT=5