aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libimobiledevice/01-libressl.patch38
-rw-r--r--testing/libimobiledevice/APKBUILD (renamed from unmaintained/libimobiledevice/APKBUILD)37
2 files changed, 52 insertions, 23 deletions
diff --git a/testing/libimobiledevice/01-libressl.patch b/testing/libimobiledevice/01-libressl.patch
new file mode 100644
index 0000000000..616c0dce74
--- /dev/null
+++ b/testing/libimobiledevice/01-libressl.patch
@@ -0,0 +1,38 @@
+From 69c42078cc5512ba6ed9cbfd2644f501d59c0717 Mon Sep 17 00:00:00 2001
+From: vmanoilov <vladinc@gmail.com>
+Date: Mon, 21 Mar 2016 23:35:01 +0000
+Subject: [PATCH] Update idevice.c
+
+---
+ src/idevice.c | 16 +++++++++-------
+ 1 file changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/src/idevice.c b/src/idevice.c
+index b776e84..b5c4407 100644
+--- a/src/idevice.c
++++ b/src/idevice.c
+@@ -676,14 +676,16 @@ LIBIMOBILEDEVICE_API idevice_error_t idevice_connection_enable_ssl(idevice_conne
+ debug_info("ERROR: Could not create SSL bio.");
+ return ret;
+ }
+- BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
+
+- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
+- if (ssl_ctx == NULL) {
+- debug_info("ERROR: Could not create SSL context.");
+- BIO_free(ssl_bio);
+- return ret;
+- }
++ BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
++
++ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
++ if (ssl_ctx == NULL) {
++ debug_info("ERROR: Could not create SSL context.");
++ BIO_free(ssl_bio);
++ return ret;
++
++ }
+
+ BIO* membp;
+ X509* rootCert = NULL;
+
diff --git a/unmaintained/libimobiledevice/APKBUILD b/testing/libimobiledevice/APKBUILD
index 1fc0fdc8bf..bef57eab74 100644
--- a/unmaintained/libimobiledevice/APKBUILD
+++ b/testing/libimobiledevice/APKBUILD
@@ -7,40 +7,31 @@ pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devic
url="http://libimobiledevice.org/"
arch="all"
license="GPL2 LGPL2.1"
-depends=""
-depends_dev=""
-makedepends="$depends_dev gnutls-dev openssl-dev libgcrypt-dev
- libusbmuxd-dev libtasn1-dev pkgconfig libtool
- automake autoconf "
-install=""
+makedepends="gnutls-dev libressl-dev libgcrypt-dev libusbmuxd-dev
+ libtasn1-dev libplist-dev libtool automake autoconf"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2"
+source="http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
+ 01-libressl.patch"
+builddir="$srcdir"/$pkgname-$pkgver
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+check() {
+ cd "$builddir"
+ make check
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--prefix=/usr \
--disable-static \
- --with-cython
- make || return 1
+ --without-cython
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="8757900ba7bbe2ef5f54342415d0223e libimobiledevice-1.2.0.tar.bz2"
-sha256sums="786b0de0875053bf61b5531a86ae8119e320edab724fc62fe2150cc931f11037 libimobiledevice-1.2.0.tar.bz2"
-sha512sums="0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589 libimobiledevice-1.2.0.tar.bz2"
+sha512sums="0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589 libimobiledevice-1.2.0.tar.bz2
+74b05241aa8202aed02e33570c950c54319526b8906862b3624edc9e586992f3bdfbdad7d7b4e4334b8550b252bad82365f0e04a2b71d1f9f0a20269f40e4ce0 01-libressl.patch"