aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-inflection/APKBUILD49
-rw-r--r--testing/py3-inflection/APKBUILD31
2 files changed, 31 insertions, 49 deletions
diff --git a/testing/py-inflection/APKBUILD b/testing/py-inflection/APKBUILD
deleted file mode 100644
index b16ec058d9..0000000000
--- a/testing/py-inflection/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
-pkgname=py-inflection
-pkgver=0.3.1
-pkgrel=1
-pkgdesc="A port of Ruby on Rails' inflector to Python"
-url="https://github.com/jpvanhal/inflection"
-arch="noarch"
-license="MIT"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends=""
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-options="!check" # no test suite
-source="$pkgname-$pkgver.tar.gz::https://github.com/jpvanhal/inflection/archive/$pkgver.tar.gz"
-builddir="$srcdir"/inflection-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py --quiet build
- python3 setup.py --quiet build
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad py-inflection-0.3.1.tar.gz"
diff --git a/testing/py3-inflection/APKBUILD b/testing/py3-inflection/APKBUILD
new file mode 100644
index 0000000000..3d0cada80d
--- /dev/null
+++ b/testing/py3-inflection/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py3-inflection
+_pkgname=inflection
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A port of Ruby on Rails' inflector to Python"
+url="https://github.com/jpvanhal/inflection"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends=""
+options="!check" # no test suite
+source="$_pkgname-$pkgver.tar.gz::https://github.com/jpvanhal/inflection/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-inflection" # Backkwards compatibility
+provides="py-inflection=$pkgver-r$pkgrel" # Backkwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad py-inflection-0.3.1.tar.gz"