aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/uncrustify/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/uncrustify/APKBUILD b/community/uncrustify/APKBUILD
index e10da258a1..4891f366bc 100644
--- a/community/uncrustify/APKBUILD
+++ b/community/uncrustify/APKBUILD
@@ -1,18 +1,17 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=uncrustify
pkgver=0.69.0
-pkgrel=0
+pkgrel=1
pkgdesc="A source code beautifier"
url="https://github.com/uncrustify/uncrustify"
arch="all"
-license="GPL-2.0"
-makedepends="cmake python2"
+license="GPL-2.0-or-later"
+makedepends="cmake python3"
subpackages="$pkgname-doc"
-source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://downloads.sourceforge.net/uncrustify/uncrustify-$pkgver.tar.gz"
builddir="$srcdir"
build() {
- cd "$builddir"
[ "$CARCH" = "s390x" ] && sed -i '/^12004/d' tests/c-sharp.test
mkdir -p build
cd build
@@ -26,7 +25,6 @@ check() {
}
package() {
- cd "$builddir"
install -d -m755 "$pkgdir"/usr/share/$pkgname
install -m644 etc/*.cfg "$pkgdir"/usr/share/$pkgname
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING