aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/inkscape/APKBUILD9
-rw-r--r--community/inkscape/poppler-082.patch41
-rw-r--r--community/texlive/APKBUILD2
-rw-r--r--main/poppler/APKBUILD2
-rw-r--r--testing/kitinerary/APKBUILD9
5 files changed, 55 insertions, 8 deletions
diff --git a/community/inkscape/APKBUILD b/community/inkscape/APKBUILD
index 163c28dbe5..a3eb3325b8 100644
--- a/community/inkscape/APKBUILD
+++ b/community/inkscape/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
pkgver=0.92.4
-pkgrel=3
+pkgrel=4
pkgdesc="A vector-based drawing program - svg compliant"
url="https://inkscape.org/"
arch="all"
@@ -27,7 +27,9 @@ makedepends="
depends="desktop-file-utils"
checkdepends="bash py-lxml py-numpy>=1.14.3-r1"
subpackages="$pkgname-doc $pkgname-lang $pkgname-view"
-source="https://launchpad.net/inkscape/${pkgver%.*}.x/$pkgver/+download/inkscape-$pkgver.tar.bz2"
+source="https://launchpad.net/inkscape/${pkgver%.*}.x/$pkgver/+download/inkscape-$pkgver.tar.bz2
+ poppler-082.patch
+ "
options="!check" # cxxtest hangs at least on x86_64
builddir="$srcdir/$pkgname-$pkgver"
@@ -87,4 +89,5 @@ doc() {
"$subpkgdir"/usr/share/inkscape
}
-sha512sums="b9034605a79cd8aea808edf42e284819951ae1ea67778f0922f4c10224e94aca6c844acbc2294625773f0a7047d4e32ccdada876238a792a2c17db172c88e120 inkscape-0.92.4.tar.bz2"
+sha512sums="b9034605a79cd8aea808edf42e284819951ae1ea67778f0922f4c10224e94aca6c844acbc2294625773f0a7047d4e32ccdada876238a792a2c17db172c88e120 inkscape-0.92.4.tar.bz2
+adf360e99aaf2635a227bd3b59e03db688eef4713858cfbae2f02ed6368d4314cd490f53da3126555d6fc9a2b28072137c79169c18515331acd83ca643287432 poppler-082.patch"
diff --git a/community/inkscape/poppler-082.patch b/community/inkscape/poppler-082.patch
new file mode 100644
index 0000000000..69b8b5414b
--- /dev/null
+++ b/community/inkscape/poppler-082.patch
@@ -0,0 +1,41 @@
+diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
+index c52675e..0b9ba15 100644
+--- a/src/extension/internal/pdfinput/pdf-parser.cpp
++++ b/src/extension/internal/pdfinput/pdf-parser.cpp
+@@ -2414,7 +2414,7 @@ void PdfParser::doShowText(GooString *s) {
+ int wMode;
+ double riseX, riseY;
+ CharCode code;
+- Unicode *u = NULL;
++ const Unicode *u = NULL;
+ double x, y, dx, dy, tdx, tdy;
+ double originX, originY, tOriginX, tOriginY;
+ double oldCTM[6], newCTM[6];
+
+diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
+index dd5e710..036fc70 100644
+--- a/src/extension/internal/pdfinput/svg-builder.cpp
++++ b/src/extension/internal/pdfinput/svg-builder.cpp
+@@ -1379,7 +1379,7 @@ void SvgBuilder::beginString(GfxState *state) {
+ void SvgBuilder::addChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+- CharCode /*code*/, int /*nBytes*/, Unicode *u, int uLen) {
++ CharCode /*code*/, int /*nBytes*/, const Unicode *u, int uLen) {
+
+
+ bool is_space = ( uLen == 1 && u[0] == 32 );
+diff --git a/src/extension/internal/pdfinput/svg-builder.h b/src/extension/internal/pdfinput/svg-builder.h
+index 34b42e1..6fe62cc 100644
+--- a/src/extension/internal/pdfinput/svg-builder.h
++++ b/src/extension/internal/pdfinput/svg-builder.h
+@@ -141,7 +141,7 @@ public:
+ void addChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+- CharCode code, int nBytes, Unicode *u, int uLen);
++ CharCode code, int nBytes, const Unicode *u, int uLen);
+ void beginTextObject(GfxState *state);
+ void endTextObject(GfxState *state);
+
+
diff --git a/community/texlive/APKBUILD b/community/texlive/APKBUILD
index 70b906c877..0280e8e97f 100644
--- a/community/texlive/APKBUILD
+++ b/community/texlive/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=texlive
pkgver=20190410
-pkgrel=4
+pkgrel=5
pkgdesc="Comprehensive TeX document production system"
url="http://tug.org/texlive/"
arch="all !ppc64le"
diff --git a/main/poppler/APKBUILD b/main/poppler/APKBUILD
index 8b306c30ee..a2789fdb37 100644
--- a/main/poppler/APKBUILD
+++ b/main/poppler/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=poppler
pkgver=0.82.0
-pkgrel=0
+pkgrel=1
pkgdesc="PDF rendering library based on xpdf 3.0"
url="https://poppler.freedesktop.org/"
arch="all"
diff --git a/testing/kitinerary/APKBUILD b/testing/kitinerary/APKBUILD
index e605836cd8..c6f2fe725d 100644
--- a/testing/kitinerary/APKBUILD
+++ b/testing/kitinerary/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kitinerary
pkgver=19.08.2
-pkgrel=1
+pkgrel=2
arch="all"
url="https://kontact.kde.org/"
pkgdesc="Data model and extraction system for travel reservation information"
@@ -22,7 +22,9 @@ makedepends="
zlib-dev
libxml2-dev
"
-source="https://download.kde.org/stable/applications/$pkgver/src/kitinerary-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/kitinerary-$pkgver.tar.xz
+ poppler-082.patch::https://github.com/KDE/kitinerary/commit/0f8b2babcc69c490ae6548bda7ceeb1ffd27a9e3.patch
+ "
subpackages="$pkgname-dev $pkgname-lang"
prepare() {
@@ -54,4 +56,5 @@ package() {
DESTDIR="$pkgdir" make install
}
-sha512sums="a9278d0b35ecc30e357ccd5d6b1d2aca4237c7a831919478c3628d83bff0583a9ed3e5155cc9df7d42636e2a16fc608c56297755cfddab11d0ae51cf3639ef73 kitinerary-19.08.2.tar.xz"
+sha512sums="a9278d0b35ecc30e357ccd5d6b1d2aca4237c7a831919478c3628d83bff0583a9ed3e5155cc9df7d42636e2a16fc608c56297755cfddab11d0ae51cf3639ef73 kitinerary-19.08.2.tar.xz
+26fc4037196d636641ef696de0334c04325dafce6bbbee2109fffa02d7aeefe4958aa124de8cc1d6a08415936e43cd7d0cf1afed463d15f95f8d3c10e2063434 poppler-082.patch"