aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/perl-carp-assert/APKBUILD (renamed from testing/perl-carp-assert/APKBUILD)17
1 files changed, 9 insertions, 8 deletions
diff --git a/testing/perl-carp-assert/APKBUILD b/community/perl-carp-assert/APKBUILD
index 7645e9abe5..317acea5d0 100644
--- a/testing/perl-carp-assert/APKBUILD
+++ b/community/perl-carp-assert/APKBUILD
@@ -1,28 +1,29 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-carp-assert
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Carp-Assert
pkgver=0.21
-pkgrel=2
+pkgrel=3
pkgdesc="Perl module for executable comments"
-url="https://metacpan.org/release/Carp-Assert"
+url="https://metacpan.org/release/Carp-Assert/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/Carp-Assert-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}