aboutsummaryrefslogtreecommitdiffstats
path: root/backports/perl-lwp-protocol-https/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'backports/perl-lwp-protocol-https/APKBUILD')
-rw-r--r--backports/perl-lwp-protocol-https/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/backports/perl-lwp-protocol-https/APKBUILD b/backports/perl-lwp-protocol-https/APKBUILD
new file mode 100644
index 0000000000..032553d78f
--- /dev/null
+++ b/backports/perl-lwp-protocol-https/APKBUILD
@@ -0,0 +1,39 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-lwp-protocol-https
+_pkgreal=LWP-Protocol-https
+pkgver=6.04
+pkgrel=0
+pkgdesc="Provide https support for LWP::UserAgent"
+url="http://search.cpan.org/dist/LWP-Protocol-https/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-libwww perl-io-socket-ssl perl-mozilla-ca perl-net-http"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="1b422a7d3b5fed1eb4d748fdc9fd79a4 LWP-Protocol-https-6.04.tar.gz"
+sha256sums="1ef67750ee363525cf729b59afde805ac4dc80eaf8d36ca01082a4d78a7af629 LWP-Protocol-https-6.04.tar.gz"
+sha512sums="93b40c2ebc75c1ab4a2c2d0c58a2eeccd619baaa71257eecc0fce970362811404ec9a115ad8848663ac9020ba03a776165f2ae6952ff54e1c1d58299b603f1b1 LWP-Protocol-https-6.04.tar.gz"