aboutsummaryrefslogtreecommitdiffstats
path: root/community/emscripten-fastcomp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/emscripten-fastcomp/APKBUILD')
-rw-r--r--community/emscripten-fastcomp/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/emscripten-fastcomp/APKBUILD b/community/emscripten-fastcomp/APKBUILD
index fdc5c25d9e..bdab4978a7 100644
--- a/community/emscripten-fastcomp/APKBUILD
+++ b/community/emscripten-fastcomp/APKBUILD
@@ -8,7 +8,7 @@
pkgname=emscripten-fastcomp
# Keep in sync with package emscripten!
pkgver=1.37.10
-pkgrel=1
+pkgrel=2
pkgdesc="The Clang + LLVM backend for Emscripten"
url="https://kripken.github.io/emscripten-site/"
arch="all"
@@ -18,7 +18,9 @@ makedepends="cmake paxmark zlib-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/kripken/$pkgname/archive/$pkgver.tar.gz
$pkgname-clang-$pkgver.tar.gz::https://github.com/kripken/$pkgname-clang/archive/$pkgver.tar.gz
llvm-fix-build-with-musl-libc.patch
- llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch"
+ llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
+ llvm-fix-return-type-in-ORC-readMem-client-interface.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # some tests are broken, don't bother with it for now
@@ -81,4 +83,5 @@ package() {
sha512sums="8a7ab29f2b239eef43bfcea3359847d9566aecd1252f6f27685e43bb71ef9031d3dffc14f07fdf97979461ea4e07140510aebec315ab4fdfaec9fcb944370c6a emscripten-fastcomp-1.37.10.tar.gz
54442b598001204420087b7ff6168c34a626e39a3992a343294cdc9c9a93020ca8de19365d15afc97d35ff94f584f50663e0b843696596f3ad3441608d974270 emscripten-fastcomp-clang-1.37.10.tar.gz
f84cd65d7042e89826ba6e8d48c4c302bf4980da369d7f19a55f217e51c00ca8ed178d453df3a3cee76598a7cecb94aed0775a6d24fe73266f82749913fc3e71 llvm-fix-build-with-musl-libc.patch
-19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch"
+19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
+f57c734687c8ceae8d1bbfcbfdeecb75a5059a112967f4ba639d78d2484e0cc1deabf02ba2d3a6f5283443bf8b3230f38ad143800f8f3327cca0d2691a3ddc3d llvm-fix-return-type-in-ORC-readMem-client-interface.patch"