aboutsummaryrefslogtreecommitdiffstats
path: root/community/fmt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fmt/APKBUILD')
-rw-r--r--community/fmt/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/fmt/APKBUILD b/community/fmt/APKBUILD
index fb402aa026..77e80423b9 100644
--- a/community/fmt/APKBUILD
+++ b/community/fmt/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname="fmt"
-pkgver="5.3.0"
+pkgver="6.0.0"
pkgrel=0
pkgdesc="Open-source formatting library for C++"
url="https://fmt.dev/latest/index.html"
arch="all"
-license="BSD-2-Clause"
+license="MIT"
makedepends="cmake doxygen"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/fmtlib/fmt/releases/download/$pkgver/fmt-$pkgver.zip
- 0001-install-pkg-config-file-into-libdir.patch"
+source="https://github.com/fmtlib/fmt/releases/download/$pkgver/fmt-$pkgver.zip"
options="!check" # 93% tests passed, 1 tests failed out of 14
build() {
@@ -23,7 +22,6 @@ build() {
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
${CMAKE_CROSSOPTS} .
make
}
@@ -36,5 +34,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3075553cb8200cf268e77339ccc7faf834f7af4dabaf5a7ddbb2de9969eb94e6d51e7ba943692e6be54e016907b72eb5e0d9b16a3873e52ff41596660b4f1186 fmt-5.3.0.zip
-75f5fdf0b3a47e5a31a608c14274e0c9d6f0600e0847f8607f4e62966c944ddbbed5ea3287b3f714e2ca56d242ca68bb68b5a1c77ca516a6e19033195d30c6b0 0001-install-pkg-config-file-into-libdir.patch"
+sha512sums="c2d458c341ded52c3df0ce4ad45e2acc4d486200e97feb53d08de7802c44ec2e0284dde2beccc27db72fdd7bd9f06413c977dc3de7184250d6853222a750bcc7 fmt-6.0.0.zip"