aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-crypt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-crypt/APKBUILD')
-rw-r--r--community/git-crypt/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/git-crypt/APKBUILD b/community/git-crypt/APKBUILD
new file mode 100644
index 0000000000..037fdc3799
--- /dev/null
+++ b/community/git-crypt/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Laurent Arnoud <laurent@spkdev.net>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Laurent Arnoud <laurent@spkdev.net>
+pkgname=git-crypt
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Transparent file encryption in git"
+url="https://www.agwa.name/projects/git-crypt"
+arch="all"
+license="GPL-3.0-or-later"
+depends="git"
+options="!check" # No test suite
+makedepends="docbook-xml docbook-xsl openssl-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/AGWA/$pkgname/archive/$pkgver.tar.gz
+ 0001-add-merge-driver.patch
+ 0002-keep-empty-files-unencrypted.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" ENABLE_MAN=yes install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="06fd9f6dbdc5c9fa9196f3e81a87cd3688089623b2658daf9c98809d5ca14df0b7ca69fdfe8279abf575957c366f2f93bd5a6885092eb533bd0d1ed9fe9dfac5 git-crypt-0.6.0.tar.gz
+90da8f4c6f084ec35a753969908eb1b1c4e2ff3bc6b0eb22aa3d4b88c712c2f9db09d7ad404ec2fb0e6addeb6f4c724b7008ed2687ad3892ea4bf16f4685c975 0001-add-merge-driver.patch
+136b5ad3a197f462878210462ce4d4bac6978d9ef67f5a4f49acedd58c48491c245f8649885bcc2bed43d642f7e5652d32acf12861b28582b6658482168f7088 0002-keep-empty-files-unencrypted.patch"