aboutsummaryrefslogtreecommitdiffstats
path: root/community/gotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gotop/APKBUILD')
-rw-r--r--community/gotop/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
index 86b9b86836..b1a0f49b31 100644
--- a/community/gotop/APKBUILD
+++ b/community/gotop/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="AGPL-3.0-or-later"
depends="procps" # Remove once #138 on cjbassi/gotop is fixed
makedepends="git go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cjbassi/gotop/archive/${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cjbassi/gotop/archive/$pkgver.tar.gz"
builddir="$srcdir/src/github.com/cjbassi/gotop"
prepare() {
@@ -29,4 +29,9 @@ check() {
package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
}
+
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
sha512sums="012cc627fa7013409f3775d5bf2528e25e275fc285fea7ae93a1afec33474c923cc6cd9accb24fce479ab229c98d6438cc9f5eb7dea37f72c1905516d5fdbf6e gotop-3.0.0.tar.gz"