aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3wm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/i3wm/APKBUILD')
-rw-r--r--community/i3wm/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
index 1e5b183e32..5a0c030676 100644
--- a/community/i3wm/APKBUILD
+++ b/community/i3wm/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=i3wm
-pkgver=4.16.1
-pkgrel=2
+pkgver=4.17
+pkgrel=0
pkgdesc="Improved dynamic tiling window manager"
url="https://i3wm.org"
arch="all"
@@ -34,23 +34,17 @@ source="
i3wm-musl-glob-tilde.patch
"
builddir="$srcdir/i3-$pkgver"
+options="!check" # missing perl bindings for libxcb
build() {
- cd "$builddir"
./configure \
- --prefix="/usr" \
+ --prefix=/usr \
--disable-builddir \
- --sysconfdir="/etc"
+ --sysconfdir=/etc
make
}
-check() {
- cd "$builddir"
- ./i3 --version > /dev/null
-}
-
package() {
- cd "$builddir"
make DESTDIR="$pkgdir/" install
install -d "$pkgdir/usr/share/man/man1"
@@ -64,5 +58,5 @@ savetree() {
mv "$pkgdir"/usr/bin/i3-save-tree "$subpkgdir"/usr/bin/
}
-sha512sums="3e328f8c7216697c5e484ca854605350f78844e24cc6cfb9c10e71368c2c0457387a14f819abdf8be2370d437889297f452fbf63f3924766ca81c157ab27e1b0 i3-4.16.1.tar.bz2
+sha512sums="88fef7331c8e76126559d1a200bb7f840980e73e1aebad838830d86d9d2225c0f12c969a724aae3d8367ee58e898c55e21e7bc1e6bc1d3b5b5375ce0af969402 i3-4.17.tar.bz2
c6ae3f22d0303da5de7ca4c92734b043a76d7447559fe2ffc308a8d135076cf05ee53ef63eb28c1bd628a1edfb2d1a0ed2d090836cb5fc70f2b882ee1105dad3 i3wm-musl-glob-tilde.patch"