aboutsummaryrefslogtreecommitdiffstats
path: root/community/libaccounts-glib
diff options
context:
space:
mode:
Diffstat (limited to 'community/libaccounts-glib')
-rw-r--r--community/libaccounts-glib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/libaccounts-glib/APKBUILD b/community/libaccounts-glib/APKBUILD
new file mode 100644
index 0000000000..836971251d
--- /dev/null
+++ b/community/libaccounts-glib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libaccounts-glib
+pkgver=1.24
+pkgrel=1
+arch="all"
+url="https://gitlab.com/accounts-sso/libaccounts-glib"
+pkgdesc="GLib-based client library for the accounts database"
+license="LGPL-2.1-or-later"
+depends_dev="libxml2-dev sqlite-dev check-dev py3-gobject3 gobject-introspection-dev"
+makedepends="$depends_dev meson ninja vala python3 gtk-doc glib-dev"
+source="https://gitlab.com/accounts-sso/libaccounts-glib/-/archive/VERSION_$pkgver/libaccounts-glib-VERSION_$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # Requires a systemd feature
+builddir="$srcdir/$pkgname-VERSION_$pkgver"
+
+build() {
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="d4e6906f642c7a196cb42172f31345f58037d528950bee3af2b8cb388aea386056cbaa22f0e7c604a4e00038b231e9ee455f6a1d48f82344cfc0037ad7251b7c libaccounts-glib-VERSION_1.24.tar.gz"