aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmicrohttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmicrohttpd/APKBUILD')
-rw-r--r--community/libmicrohttpd/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/libmicrohttpd/APKBUILD b/community/libmicrohttpd/APKBUILD
new file mode 100644
index 0000000000..0e944a29b7
--- /dev/null
+++ b/community/libmicrohttpd/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmicrohttpd
+pkgver=0.9.70
+pkgrel=0
+pkgdesc="A small C library that is supposed to make it easy to run an HTTP server as part of another application."
+url="https://www.gnu.org/software/libmicrohttpd/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="curl-dev libgcrypt-dev gnutls-dev automake autoconf libtool"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="https://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-$pkgver.tar.gz
+ disable-test_options.patch"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-largefile \
+ --enable-curl \
+ --enable-https \
+ --enable-messages
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$builddir"/src/include/platform.h \
+ "$pkgdir"/usr/include/platform.h
+}
+
+sha512sums="391293688d5ef51cf8d918294000384cb291f46bf767295af5a97123c06c75573d480a6c4b2486712b53636fe3e5dc1f8827ccf4335ac435ec85c3529733d8f5 libmicrohttpd-0.9.70.tar.gz
+7bbd8d2571f2bf7d06c956cc5e5decf154139baa1a716b43501b822b18a396b2cc97efd72118bc3dd5e20439611eb333730c436fe9f0a1ce2cf928066520e619 disable-test_options.patch"