aboutsummaryrefslogtreecommitdiffstats
path: root/community/mongodb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mongodb/APKBUILD')
-rw-r--r--community/mongodb/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/mongodb/APKBUILD b/community/mongodb/APKBUILD
index 1de045bc9c..74061f23f6 100644
--- a/community/mongodb/APKBUILD
+++ b/community/mongodb/APKBUILD
@@ -3,9 +3,9 @@
pkgname=mongodb
pkgver=4.0.4
pkgrel=0
-pkgdesc='A high-performance, open source, schema-free document-oriented database'
-url='http://www.mongodb.org'
-arch='x86_64 ppc64le'
+pkgdesc="A high-performance, open source, schema-free document-oriented database"
+url="http://www.mongodb.org"
+arch="x86_64 ppc64le aarch64"
options="!check" # out of disk space (>35GB)
license='AGPL3'
pkgusers="mongodb"
@@ -44,9 +44,12 @@ _buildopts="
--ssl \
"
+case $CARCH in
+ aarch64) _buildopts="$_buildopts CCFLAGS=-march=armv8-a+crc" ;;
+esac
+
build() {
cd "$builddir"
-
export SCONSFLAGS="$MAKEFLAGS"
scons $_buildopts --prefix=$pkgdir/usr core
}