aboutsummaryrefslogtreecommitdiffstats
path: root/community/mysecureshell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mysecureshell/APKBUILD')
-rw-r--r--community/mysecureshell/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/mysecureshell/APKBUILD b/community/mysecureshell/APKBUILD
new file mode 100644
index 0000000000..2c8b62d904
--- /dev/null
+++ b/community/mysecureshell/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=mysecureshell
+pkgver=2.00
+pkgrel=0
+pkgdesc="A solution which has been made to bring more features to sftp/scp protocol given by OpenSSH."
+url="https://github.com/mysecureshell/mysecureshell"
+arch="all"
+license="GNU"
+depends="openssh"
+makedepends="musl-dev"
+install="$pkgname.post-install $pkgname.post-deinstall"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
+ 0001-include-types.h.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-shutfile=/var/lib/misc/sftp.shut \
+ || return 1
+ make all
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="f5025cf44a607e8cbb360c2d74da2076 mysecureshell-2.00.tar.gz
+b3bfc3ef1cfac921c32e4193b65566bf 0001-include-types.h.patch"
+sha256sums="05fbcc407a61a06f980581320e7df46bbb7cf2d2ae253cae79f716bda0940890 mysecureshell-2.00.tar.gz
+5c0d585ee41722d355feac65e8407e7a1c692f7ec6ae46fa33b3858ccc52d0d4 0001-include-types.h.patch"
+sha512sums="956404bfcb48e2838e8b0eeea9ee5b07de70fd51480f3c98c1029c627d914adde483bb85e877e1ca206c376ed803205a20e1b90a74c5218d9cc9338a9a1f626b mysecureshell-2.00.tar.gz
+ba0e5e02740118d9c6d7ec3e4c122b90269ebf2dd73a35e409cb118a125989debf8149ed87bb3b96bed755ce886ffa6ebf293b70937f93f02c73e71304250aad 0001-include-types.h.patch"