aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/opam/APKBUILD')
-rw-r--r--community/opam/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 7306f66851..ba96c31029 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -1,18 +1,17 @@
# Contributor: Michael Zuo <muh.muhten@gmail.com>
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
-# FIXME: lib-ext downloads dependencies; package them and use system-provided!
pkgname=opam
-pkgver=1.2.2
-pkgrel=4
+pkgver=2.0.1
+pkgrel=0
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !armv7 !s390x" # ocaml not avail on excluded platforms
-license="LGPL-3.0"
-depends="ocaml ocaml-camlp4 curl tar unzip rsync aspcud patch"
-makedepends="ocaml-compiler-libs ocaml-camlp4-dev"
-source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
- fix-default-stubsdir.patch"
+license="LGPL-2.1"
+depends="ocaml curl xz tar unzip rsync patch bubblewrap bash"
+makedepends="ocaml-compiler-libs"
+source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-full-$pkgver"
+subpackages="$pkgname-doc"
build() {
cd "$builddir"
@@ -26,9 +25,8 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var
- # -unsafe-string needed to make it build with ocaml >=4.06.
- OCAMLFLAGS="-unsafe-string" \
- make -j1 lib-ext all
+ make -j1 lib-ext
+ make -j1 all
}
package() {
@@ -36,5 +34,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f095ef4c02e6a411ee115b508c7dc21cf6480f60ad5d84ed5ce5868afa1f6225ead0eb6703763d803edc22595e83db67cdd1a4ecab50ee2c62c20965b0542436 opam-full-1.2.2.tar.gz
-704a9d36b93267a982fd5bad99637338afab6b0a8edbbb127e17065e27d54ef752a10565e8078e1c4d63e16f95f5df11fd1f26de4925042a57b0dd678fe33d2e fix-default-stubsdir.patch"
+check() {
+ cd "$builddir"
+ make tests
+}
+
+sha512sums="add6cd77067cddadd4be5d79699713211f5f2796c1e1931048eb5fc4f0127eca56e1f81d43335327ae04e2144186d9ce759e844d2a125ef27f22c26cd8153e3c opam-full-2.0.1.tar.gz"