aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-datetime-format-natural
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-datetime-format-natural')
-rw-r--r--community/perl-datetime-format-natural/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/perl-datetime-format-natural/APKBUILD b/community/perl-datetime-format-natural/APKBUILD
new file mode 100644
index 0000000000..4019cea412
--- /dev/null
+++ b/community/perl-datetime-format-natural/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=perl-datetime-format-natural
+_pkgreal=DateTime-Format-Natural
+pkgver=1.08
+pkgrel=0
+pkgdesc="Create machine readable date/time with natural parsing logic"
+url="https://metacpan.org/release/DateTime-Format-Natural"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+cpandepends="perl-datetime-timezone perl-clone perl-params-validate
+ perl-list-moreutils perl-datetime perl-boolean"
+cpanmakedepends="perl-module-util perl-test-mocktime perl-date-calc
+ perl-mro-compat perl-role-tiny"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/SC/SCHUBIGER/DateTime-Format-Natural-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="92ce61df98bb4d15b41597a99d0c19972c2f1f24352c5af365d41afc13efde79f9e5fb23551208450e8fc0ee499f1a7cd6aa8ccd44f16991f3fccf48e8a6c635 DateTime-Format-Natural-1.08.tar.gz"