aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-text-unidecode/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-text-unidecode/APKBUILD')
-rw-r--r--community/perl-text-unidecode/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/perl-text-unidecode/APKBUILD b/community/perl-text-unidecode/APKBUILD
new file mode 100644
index 0000000000..cf163f6c5f
--- /dev/null
+++ b/community/perl-text-unidecode/APKBUILD
@@ -0,0 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-text-unidecode
+_pkgreal=Text-Unidecode
+pkgver=1.30
+pkgrel=0
+pkgdesc="Provide plain ASCII transliterations of Unicode text"
+url="https://metacpan.org/release/Text-Unidecode/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/SB/SBURKE/Text-Unidecode-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="194f8aba0dcdc7a53338b86370b7cfb6c60d4a8982ada6084f0eb0ccd66ce461b831b6daf04932f039ff1b983dc3cd0c0ced1e8b455955d2699c36120b41a526 Text-Unidecode-1.30.tar.gz"