aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5-phpmailer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php5-phpmailer/APKBUILD')
-rw-r--r--community/php5-phpmailer/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/php5-phpmailer/APKBUILD b/community/php5-phpmailer/APKBUILD
new file mode 100644
index 0000000000..731eeb6042
--- /dev/null
+++ b/community/php5-phpmailer/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+_php=php5
+pkgname=${_php}-phpmailer
+pkgver=5.2.20
+pkgrel=0
+pkgdesc="PHP class for SMTP mailing"
+url="https://github.com/PHPMailer/PHPMailer"
+arch="noarch"
+license="LGPL"
+depends="$_php"
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/PHPMailer/PHPMailer/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir/PHPMailer-$pkgver"
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ install -d -m755 "$pkgdir"/usr/share/pear
+ install -D -m644 "$builddir"/class.*.php "$pkgdir"/usr/share/pear || return 1
+}
+
+md5sums="9b23523ce070855abfdd79ff06d85afd php5-phpmailer-5.2.20.tar.gz"
+sha256sums="4716acef60503f345323849842f3138a8453c178d3829477553bf1e347664976 php5-phpmailer-5.2.20.tar.gz"
+sha512sums="c8dab5decd5012687b2e1d7a4ce2a3a605a6c3589b1f747960faa6080fb1c65580c1dd0f0cba52fc3735e4cf357c31237b51a6ade00c5dbffc57c27328d15018 php5-phpmailer-5.2.20.tar.gz"