aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-ssh2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-pecl-ssh2/APKBUILD')
-rw-r--r--community/php7-pecl-ssh2/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/php7-pecl-ssh2/APKBUILD b/community/php7-pecl-ssh2/APKBUILD
new file mode 100644
index 0000000000..034e646478
--- /dev/null
+++ b/community/php7-pecl-ssh2/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php7-pecl-ssh2
+_pkgreal=ssh2
+pkgver=1.1.2
+pkgrel=3
+pkgdesc="PHP extension provide bindings for the libssh2 library - PECL"
+url="https://pecl.php.net/package/ssh2"
+arch="all"
+license="PHP-3.01"
+makedepends="php7-dev autoconf libssh2-dev re2c"
+options="!check" # Depends on setup of user, cert & running ssh server
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-ssh2=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-ssh2" # for backward compatibility
+
+build() {
+ cd "$builddir"
+
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir/" install
+
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="36793191448745b8a9b3cc628fe9fb431480792c7a2ff0bf2eccd58cda1cf944933be1d301c455d4a6f3dabf7e04ffef248bc402a8ff99bfafcba0deddb25c36 php7-pecl-ssh2-1.1.2.tgz"