aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7/install-pear.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7/install-pear.patch')
-rw-r--r--community/php7/install-pear.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/php7/install-pear.patch b/community/php7/install-pear.patch
new file mode 100644
index 0000000000..18747be94b
--- /dev/null
+++ b/community/php7/install-pear.patch
@@ -0,0 +1,15 @@
+--- ./pear/Makefile.frag.orig 2013-04-12 07:02:27.041602514 +0000
++++ ./pear/Makefile.frag 2013-04-12 07:04:09.065836822 +0000
+@@ -2,8 +2,11 @@
+
+ peardir=$(PEAR_INSTALLDIR)
+
++# help the built php to find xml extension so we can install pear
++PEAR_INSTALL_XML_FLAGS = -d extension_dir="$(top_builddir)/modules" -d extension=xml.so
++
+ # Skip all php.ini files altogether
+-PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0
++PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0 $(PEAR_INSTALL_XML_FLAGS)
+
+ WGET = `which wget 2>/dev/null`
+ FETCH = `which fetch 2>/dev/null`