aboutsummaryrefslogtreecommitdiffstats
path: root/community/pianobar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pianobar/APKBUILD')
-rw-r--r--community/pianobar/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/pianobar/APKBUILD b/community/pianobar/APKBUILD
new file mode 100644
index 0000000000..5e49863345
--- /dev/null
+++ b/community/pianobar/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=pianobar
+pkgver=2017.08.30
+pkgrel=0
+pkgdesc="commandline player for pandora webradio"
+url="https://github.com/PromyLOPh/pianobar"
+arch="all"
+license="MIT"
+depends_dev="ffmpeg-dev libao-dev libgcrypt-dev gnutls-dev json-c-dev curl-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-doc"
+source="pianobar-${pkgver}.tar.gz::https://github.com/PromyLOPh/pianobar/archive/$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}
+
+sha512sums="c2cd425377bacc35899a72021fb24c8cc506a5ced9bab74fd2ad6ef4b589788bb8e6294fcd5dade5c8bac31fe52866214bebd6c89989e2b929f12542d90a3b6d pianobar-2017.08.30.tar.gz"