aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-browser-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-browser-integration/APKBUILD')
-rw-r--r--community/plasma-browser-integration/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index 8e9e3bc55f..827ee7c42e 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -1,18 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-browser-integration
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
arch="all"
url="https://community.kde.org/Plasma/Browser_Integration"
license="GPL-3.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev kdbusaddons-dev knotifications-dev krunner-dev kactivities-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev kdbusaddons-dev knotifications-dev krunner-dev kactivities-dev purpose-dev kfilemetadata-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-browser-integration-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -20,11 +27,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="667c5ef2dd0529e6c567e9d3e34e8e6df73e0101605ccc4a6712e7f47b6824407495102ddc9b800e411f53a1fdf0132caebf6d955c39e7a80b7ab6569d02d1b4 plasma-browser-integration-5.16.5.tar.xz"
+sha512sums="8991e0c10130529005d0009db429d8357dcfeb58acadb745fb82d20020f5666e5356ba9e5ad26fc75fded95ff2550e56247acb8ef1d471eb8cba9666330877c6 plasma-browser-integration-5.17.0.tar.xz"