aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'community/plasma-desktop')
-rw-r--r--community/plasma-desktop/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index 2b71fa7990..796e5cdf53 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -1,8 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
-pkgver=5.18.4
-_pkgver=5.18.4.1
+pkgver=5.18.5
pkgrel=0
pkgdesc="KDE Plasma Desktop"
# s390x, mips, mips64 blocked by ibus
@@ -51,17 +50,16 @@ depends_dev="
"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$_pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang knetattach"
options="!check" # Requires running dbus
-builddir="$srcdir/$pkgname-$_pkgver"
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make -C build
+ cmake --build build
}
check() {
@@ -70,7 +68,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --build build --target install
rm "$pkgdir"/usr/bin/knetattach
rm "$pkgdir"/usr/share/applications/org.kde.knetattach.desktop
@@ -83,4 +81,4 @@ knetattach() {
cd "$builddir"/build/knetattach
DESTDIR="$subpkgdir" make install
}
-sha512sums="4cac140ddca8ce57a6e27cfac2946824db40a0adf9f0a9b6fe6079f9b899f4b145941803d4a0f1c575a27a8c76d6a7e889c3218287a126efedd9e722fa9d7089 plasma-desktop-5.18.4.1.tar.xz"
+sha512sums="14f86d1158f976e8f0fbf80fb7f5bea74393febc35592bd95806548883b3bc2e77ee55cc300119275ad322f6b8bcfbed84bb6b78a3a19868ce4695a1fb57a029 plasma-desktop-5.18.5.tar.xz"