aboutsummaryrefslogtreecommitdiffstats
path: root/community/pluma/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/pluma/APKBUILD')
-rw-r--r--community/pluma/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/pluma/APKBUILD b/community/pluma/APKBUILD
new file mode 100644
index 0000000000..f4fcb139d4
--- /dev/null
+++ b/community/pluma/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=pluma
+pkgver=1.12.1
+pkgrel=0
+pkgdesc="A small and lightweight UTF-8 text editor for the MATE"
+url="https://github.com/mate-desktop/pluma"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev intltool enchant-dev iso-codes-dev gtk+2.0-dev
+ mate-desktop-dev gtksourceview2-dev dconf-dev libsm-dev itstool
+ libxml2-utils fortify-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ 0001-fix-accessperms-in-tests.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --with-gtk=2.0 \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="23c759521d108638ea508722efc97f69 pluma-1.12.1.tar.xz
+b9b073964fd9a0f17e88f51f40078fe4 0001-fix-accessperms-in-tests.patch"
+sha256sums="f96cdc5415bb44b234ad9045520dd095c3f9d49dc965e7883d613d23af75e92c pluma-1.12.1.tar.xz
+1cb9656b6054d7e9421f4ddcc64c987fda6c976b14e59d950b17426f4b9634a4 0001-fix-accessperms-in-tests.patch"
+sha512sums="604c70567f53a556d1545a154007ceffbd33b01332a0c2b14dade6fee255b31f1d48767f3786e26973231d259ed593be028d5f4fae37ece477da78bd8cb2213c pluma-1.12.1.tar.xz
+3aa0ae2e383bcc36c63384455062954876e77995da79a757b4eb6e37f3b2e5f7139165d7bb95c193ff888d33d2682773e981bf7e44fd963e918696d64e537741 0001-fix-accessperms-in-tests.patch"