aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-twisted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-twisted/APKBUILD')
-rw-r--r--community/py-twisted/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/py-twisted/APKBUILD b/community/py-twisted/APKBUILD
new file mode 100644
index 0000000000..56fec31b3e
--- /dev/null
+++ b/community/py-twisted/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-twisted
+_pkgname=Twisted
+pkgver=19.2.1
+pkgrel=2
+pkgdesc="Asynchronous networking framework written in Python."
+url="http://twistedmatrix.com/"
+arch="all"
+license="MIT"
+depends="py-crypto py-zope-interface py-constantly py-incremental py-attrs"
+makedepends="python2-dev py-setuptools libtirpc-dev py3-setuptools python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3 $pkgname-doc"
+source="https://twistedmatrix.com/Releases/${_pkgname}/${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2"
+builddir="$srcdir"/"$_pkgname"-$pkgver
+
+build() {
+ cd "$builddir"
+ CFLAGS="$CFLAGS $(pkgconf --cflags libtirpc)" python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ _mans="pyhtmlizer.1 trial.1 twistd.1"
+ for _man in $_mans; do
+ install -m644 -D "$builddir"/docs/core/man/$_man \
+ "$pkgdir"/usr/share/man/man1/$_man
+ done
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-} py3-pyhamcrest py3-hyperlink py3-automat"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1#python}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="b358c3082a9005f7065da182cec3561d77aa34f21fc1bb20b1acdb1ad3ac7e8b0793c5f7189baec7cfa79dd19a97c3ded9381e4e376a770108f7f6b318bec5f3 Twisted-19.2.1.tar.bz2"