aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-attrs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-attrs/APKBUILD')
-rw-r--r--community/py3-attrs/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-attrs/APKBUILD b/community/py3-attrs/APKBUILD
new file mode 100644
index 0000000000..9a8070c466
--- /dev/null
+++ b/community/py3-attrs/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=py3-attrs
+pkgver=17.4.0
+pkgrel=0
+pkgdesc="Python classes without boilerplate"
+url="http://www.attrs.org"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-pytest py3-setuptools"
+source="py3-attrs-$pkgver.tar.gz::https://github.com/python-attrs/attrs/archive/$pkgver.tar.gz"
+builddir="$srcdir/attrs-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$builddir/src" python3 check.py
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="14a512009cefbadc66972380f3beeb80e28daebeef467838c3506fd33a65e555666434a2d8f7294291b431e8b787aea370e267045f30a2253463e79d0e6caa3a py3-attrs-17.4.0.tar.gz"