aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-skywriter-hat
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-skywriter-hat')
-rw-r--r--community/py3-skywriter-hat/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/community/py3-skywriter-hat/APKBUILD b/community/py3-skywriter-hat/APKBUILD
index db1ab0edd1..d96f3d8823 100644
--- a/community/py3-skywriter-hat/APKBUILD
+++ b/community/py3-skywriter-hat/APKBUILD
@@ -1,28 +1,28 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
-pkgname=py-skywriter-hat
+pkgname=py3-skywriter-hat
+_pkgname=skywriter-hat
pkgver=0.0.7
-pkgrel=0
+pkgrel=1
pkgdesc="Python libraries for the Pimoroni Skywriter board"
+options="!check" # No testsuite
url="https://github.com/pimoroni/skywriter-hat"
arch="noarch"
license="MIT"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev"
-install=""
-subpackages=""
-source="${pkgname}-${pkgver}.tar.gz::https://github.com/pimoroni/${pkgname#py-}/archive/v${pkgver}.tar.gz"
-builddir=${srcdir}/${pkgname#py-}-${pkgver}
-build() {
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pimoroni/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver/library"
+
+replaces="py-skywriter-hat" # Backwards compatibility
+provides="py-skywriter-hat=$pkgver-r$pkgrel" # Backwards compatibility
- cd "$builddir/library"
- python2 setup.py build || return 1
+build() {
+ python3 setup.py build
}
package() {
- cd "$builddir/library"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="ecce89f95fbd8402001e4896bdd2e7e371944152abd1a42ee809e065c37ca7397572669c34c6f681762811e2dbf26e8b3bfa9776d698dde17e8e3802f7e490eb py-skywriter-hat-0.0.7.tar.gz"
+sha512sums="ecce89f95fbd8402001e4896bdd2e7e371944152abd1a42ee809e065c37ca7397572669c34c6f681762811e2dbf26e8b3bfa9776d698dde17e8e3802f7e490eb py3-skywriter-hat-0.0.7.tar.gz"